FC2ブログ

Microsoft.ServiceBus.dllのバージョンをあげすぎるとMobileServiceが「Unhealthy」になる

2014.06.07.Sat.01:02
.NETバックエンドのモバイルサービスにプッシュ通知の送信を実装すると「Unhealthy」になるので、いろいろ調べたところ、nugetでパッケージをすべて更新した時に「Microsoft.ServiceBus.dll」のバージョンが"2.3.3.0"になってしまっていたのが原因っぽい。
一つずつバージョンを下げていったところ、"2.2.7.0"まで下げたところで動くようになりました。

パッケージマネージャーコンソールで、既定のプロジェクトを [プロジェクト名]Service に変えて、2.2.7.0に更新します。

PM> Install-Package WindowsAzure.ServiceBus -version 2.2.7.0


なお、


とのことなので、単にパッケージの更新をしたいときは、updatepackagesafe.png
スポンサーサイト



コメント

管理者のみに表示